Members | Sign In
All Forums > News
avatar

The Android port of Artemis is now released!

posted May 09, 2013 11:43:09 by ThomRobertson
https://play.google.com/store/apps/details?id=incandescent.game.artemis

This version of the game should work on Android 2.3 or better, OpenGL ES 2.0 or better, 480x320 or better resolution, and at least 512mb.

We haven't been approved yet by the Amazon App store; when we do I'll post that link too.
Creator of Artemis
page   first prev 1 2 3 4 5 6 next last
83 replies
avatar
darrenshield said May 18, 2013 06:26:36
Put the app on my S3 and S4. Both the tablet and phone modes are pretty, but nearly impossible to play. The icons are too small and too closely packed together.
avatar
wwjdtd said May 18, 2013 18:19:18
Ok, I found where the files are stored for the game, note: Root access IS required, it is stored at: /data/user/0/incandescent.game.artemis However, I still have to figure out how the assets are stored but that should be easy after getting where all the cache + lib files are, but the files directory is empty.

I can upload the folder as a zip if need be.
avatar
chris said May 20, 2013 15:08:57
Two thoughts:

1. Engineering without presets is practically useless.
2. All UI elements are impossibly tiny when viewed on a high-res tablet like the Nexus 10. Totally unusable on that.

Looks really nice on my Nexus 7 though.
avatar
RussJudge said May 20, 2013 15:18:04
Thanks @wwjdtd. Needing root access is a problem, (which is why I couldn't find it on my Kindle Fire), but it might be possible to at least get Artemis Mod Loader to work for this with root access.

I'm hoping the assets are pretty obvious and easy to find--and are an identical match to the PC version. In particular, there should be a vesselData.xml file, and artemis.ini file, various images of parts of the ships, and various *.snt and *.dxs files. Once all that is located, it may even be possible for me to adjust Artemis Mod Loader blind.

I do have a cheap Big Lots tablet that isn't rooted yet--but it wouldn't matter to me to root. I might try playing around with that one. Don't want to root the Kindle Fire, though--it's kind of important to me.
Russ
Author of Artemis Mod Loader.

Sign up for a free Dropbox account.
avatar
AdmlBaconStraps said May 21, 2013 04:50:01
1. Engineering without presets is practically useless.


I've never, not ONCE used presets as our ships engineer and we can comfortably win level 7 in simple sectors (so no mines to sucker punch the enemy).

I seriously don't understand why people keep saying this.

avatar
lucas99801 said May 21, 2013 05:20:39
Play with Presets and you'll notice a huge difference in the efficiency of the ship.
Hosting a Mumble (Murmur) server @ tsnfenrir.no-ip.org
Having trouble connecting to the TeamSpeak channel: http://tsnfenrir.no-ip.org/ts3
Helm Script for Numerical heading input: https://dl.dropbox.com/u/10193809/ArtemisHelmFSW.zip
Twitter: @lucas99801
Facebook: /lucastarnold
avatar
RussJudge said May 21, 2013 13:45:56
Yes, you can play without the Engineering presets, but once you start using them, you can see the difference they make--for example, if you set a preset for travel mode, with one keypress you will have warp and navigation with high energy and cooling, while you can have weapons on zero. Another, for battle mode, can speedily max out beams and torpedoes, while zeroing out warp. If you are good with doing the settings manually, you might be able to make the switch in a couple of seconds, while with the presets--it's instantaneous. With improved efficiency, you can play and win the higher and more complex levels.
Russ
Author of Artemis Mod Loader.

Sign up for a free Dropbox account.
avatar
AdmlBaconStraps said May 21, 2013 15:50:34
I don't mean to say they can't be useful (truth be told, I've used the 'reset' hotkey to default levels a bunch), just that there seems to be a feeling of 'If you can't have presets, don't even bother with the station' attitude toward it.

With a little practice you can set levels very quickly and quite accurately manually. I've heard the 'it's instant, so more efficient' argument elsewhere in the forums, but I can't honestly say I think the extra 2 seconds it'll save me is worth all the apparent fuss.

For me, it's about feeling like I'm *doing* something as opposed to just pushing a button and everything is done. Although, I'm at a point where I can breeze past all the systems clicking and get everything to within 10% or so of where I want it.
avatar
BrianPletcher said May 22, 2013 19:44:37
Tried the app on my Motorola 4, which has a mini HDMI output so I used it as a main screen hooked up to a TV while playing on my laptop. It worked pretty well! The 3D view flashed a bit when refreshing, but tactical and LRS worked great.
avatar
cmalott said May 22, 2013 20:25:35
Another, for battle mode, can speedily max out beams and torpedoes, while zeroing out warp.


while zeroing out warp.


zeroing out warp.


I've spaced Engineers for lesser sins.

I agree with BaconStraps though. I get the feeling that some Engineers put too much stock in presets. A crew and I cleared Level 11 without presets.
avatar
RobJosephson said May 24, 2013 17:17:09
Settings should never be set to zero. My engineer routinely does this, or gives say 5% to maneuvering. Much yelling ensues. He got this fantastic idea from these forums that he was saving time and energy, when he was actually impeding our progress. In addition, we have that bug where if you zero out the beams, and then try to put power back in and use them, they will not fire for about 4 or 5 minutes.
avatar
AdmlBaconStraps said May 25, 2013 05:57:05
Really? I zero stuff all the time and we've never seen a glitch like that.. Maybe try to see if there's a particular action you're taking that may be causing it and report it?

Also: it's a good idea for your engineer to zero systems that aren't being used. I routinely zero weapons and shield when we're nowhere near combat..
avatar
MichaelMesich said May 26, 2013 13:27:42
I did have a crew this weekend (all newcomers pretty much at this convention) where an intrepid engineer zeroed out warp and "wasn't told" to restore it. By the time I pointed it out the rear of the ship was molten steel. :)

It ended poorly.
avatar
ddrector said May 27, 2013 02:02:46
Trying to put it on my rooted Hyundai A7 - has a cortex A8 processor and Mali400 gpu with android 4.0, so I figure it should run fine. Can't even see it in the play store, and when I go there on my computer it will not allow download to the device. Have you got an APK file of a demo so I can try it somehow? Or do I just have to buy a more mainstream tablet?
[Last edited May 27, 2013 02:03:06]
avatar
AdmlBaconStraps said May 27, 2013 05:27:02
zeroed out warp and "wasn't told" to restore it


See, THAT's a bad engineer :P The engineer needs to know what's going on at all times so he can adjust power before the captain knows he needs it there :D
Login below to reply: