Members | Sign In
All Forums > News
avatar

The Android port of Artemis is now released!

posted May 09, 2013 11:43:09 by ThomRobertson
https://play.google.com/store/apps/details?id=incandescent.game.artemis

This version of the game should work on Android 2.3 or better, OpenGL ES 2.0 or better, 480x320 or better resolution, and at least 512mb.

We haven't been approved yet by the Amazon App store; when we do I'll post that link too.
Creator of Artemis
page   1 2 3 4 5 next last
83 replies
avatar
martinvsamuelsson said May 09, 2013 11:49:03
*Wiiii*
avatar
MarkBell said May 09, 2013 12:15:14
^^ Just Android so far, I don't know the likelihood of a Wii port :) Super stoked.
avatar
AdmlBaconStraps said May 09, 2013 12:40:34
*Squee*
avatar
varazir said May 09, 2013 13:32:14
I installed it on my Nexus 4, when I try connect to my server the client crash
If I do the other way around, set up the phone as server and connect with my computer, the client just locks up.
avatar
JSpaced said May 09, 2013 14:26:23
@Varazir: Check your server and client version numbers match up. You may need to update the version of Artemis on your computer (or downgrade it).

:)
"We should give him the send-off he deserves. He died saving us all. Prepare a Rocket-Shed for immediate launch."
avatar
emblemamerica said May 09, 2013 14:47:21
I've been waiting on buying a new phone just for this.
avatar
ThomRobertson said May 09, 2013 14:50:59
Yes, you need to have matching version numbers. EXCEPT! Versions 1.700, 1.701, and 1.702 all work together, even if there's still a mismatch warning. Those changes were very trivial.
Creator of Artemis
avatar
jfkempf said May 09, 2013 14:51:48
My morning so far:

Get to work.
Get normal mind-drudgery out of the way.
Get Bored.
Check Artemis News forum.
Notice Android client released.
Control heartbeat.
Click link.
Purchase.
Begin vibrating impatiently knowing I've got an entire day to get through before I can play.
<sad trombone>


Edit:
vibrational frequencies reached a crescendo pitch and I used my lunch hour to see what I could break. results posted in separate reply.
[Last edited May 09, 2013 19:11:09]
avatar
CaptainZach said May 09, 2013 15:01:56
Hooray! :D

I have only one gripe: WHOA NELLY is that a wall of text in the app description.
avatar
JoeGreene said May 09, 2013 16:07:15
Does the Android version support mods or just missions?
avatar
ChrisHayes said May 09, 2013 16:42:20
Sweet! Fantastic news. Thanks Thom for working hard to make this available to Android users as well as iOS users!
avatar
jfkempf said May 09, 2013 19:09:53
Just a quick FYI. I have not yet gotten to test connecting/playing, but being the impatient soul that I am, I have started the app to 'dink' around with it a bit, and have run into a minor 'gotcha' that will (might?) only affect a relative few of us.

I have a Samsung Stratosphere who's main claim to 'fame' is being the first LTE on Verizon with a physical slide-out keyboard. While Artemis is running, sliding the keyboard out or in results on the app dumping me out to the home screen. I have an original Droid at home (another slider... so we sense a pattern here?) that I will test with as well. On a side note, though a bit slow to respond, the app works just fine with the Swype keyboard (market version), and if I have the physical keyboard already extended it works fine with that as well (much MORE responsive that swype, actually). Additional quirkiness: with the physical keyboard extended when tapping on the IP address field for client mode, the screen 'moves up' to make room for the virtual keyboard (leaving large blank black block <--- alliteration, anyone?) but responding to the physical keyboard. Tapping the screen again or taping the 'back' key lowers the the screen again while still allowing typing in the IP address field.

Also (on the strat, at least), as often as not, once I've exited the app (whether intentionally or otherwise), attempts to restart the app result in a 'force close' condition until I've used my settings to clear the app data. This also seems be related to whether or not the app continues to run or not. Keeping in mind that I haven't been able to connect to my server (yet), I have found no specific way to exit the app. The 'back' function does not do it, and while the 'home' key does take me out of the app, Artemis is still listed as an active app. This is not necessarily incorrect behavior, and as long as it is an active app, I have no problems bringing the app back up and running it, but once the app is exited (via task manager), I have to 'clear data' to get past the 'force close' issue.

I will provide further data once I've had a chance to connect to my server at home.

Update: Still haven't gotten home to the server yet, but letting the application exit on its own from the 'active apps' list resulted in the same FC condition requiring me to clear data before it would run again.
[Last edited May 09, 2013 20:54:18]
avatar
ChrisHayes said May 09, 2013 19:19:39
I've started running it on an old Asus Transformer TF101 (original Tegra 2 model). It works well overall though I too have at least one issue so far. Basically, everything works fine except the Sensor station. I did a quick load up into a server at home and toyed around with it. At first, the sensor station worked just fine like everything else. However, at some point, I lost all ability to target anything. Tapping on the screen would give me coordinates for and distance to that point, but it just flat quit targeting altogether. Everything else works flawlessly (well, the video is a tad choppy but I'm tagging that one on my 2 year old tablet). I'll be running it through more tests, but that's my quick "5 minutes in" notes.
avatar
rulitawyn said May 09, 2013 21:08:40
Seems to force close alot on my samsung galaxy s iii the only playable station is comms all others crash when doing various things like when i go to warp in helm, click a damcon team in engineering or try to scan in science. also crashes when switching to different screens if using it for multiple stations

still excited to see the bugs worked out and its great to have a handheld comms device when you are a man or two down.
avatar
TreChipman said May 10, 2013 04:05:51
Downloaded it onto my MK808 for use as my server (I have it hooked up to my projector), and it seemed to work fine as the main screen, although it did seem to run a little hot. However, I think I can probably mitigate that if I drop the resolution a bit. The MK808 is a bit sluggish input-wise, but well worth it for trading in a 30 lb server for something the size and weight of a cigarette lighter (and is less than $50).

I still have to figure out how to install mods and missions, though.
[Last edited May 10, 2013 04:09:52]
I'm not a mad scientist. I'm an angry one. You'd be wise to fear the latter.

Visit Artemis Command!
Login below to reply: