Members | Sign In
All Forums > Mission Scripting
avatar

How to use AI with Arvonian Carriers

posted Feb 04, 2013 04:10:20 by TimReiff
I've been trying to get some carriers to work in my mission, but when I clear their stack, and give them at set of commands like the below, they never launch fighters. I would assume that it would be one of their first priorities, based on the "start with lowest command" priority that I thought I understood for enemy AI. Anyone have any ideas?

<create type="enemy" x="53683.0" y="0.0" z="84526.0" angle="301.9" name="E4" hullID="3002" fleetnumber="4" />
<clear_ai name="E4" />
<add_ai type="POINT_THROTTLE" value1="67858.0" value3="77714.0" value4="100.0" name="E4" />
<add_ai type="CHASE_PLAYER" value1="10000" value2="4000" name="E4" />
<add_ai type="LAUNCH_FIGHTERS" value2="10000" name="E4" />
<add_ai type="AVOID_BLACK_HOLE" value1="2000" name="E4" />
page   1
2 replies
avatar
Mike_Substelny said Feb 04, 2013 21:29:26
This may seem overly simple, but I think you want value1 instead of value2.
"Damn the torpedoes! Four bells, Captain Drayton!"

(Likely actual words of Admiral David Farragut, USN, at the battle of Mobile Bay. Four bells was the signal for the engine room to make full steam ahead).
avatar
TimReiff said Feb 04, 2013 21:32:47
Huh. I just used whatever it dumped in from the editor. I'll give that a try and let you know if it works. Thanks for the idea!

Edit: Confirmed that changing it to Value1 worked. Unfortunately saving the file in the editor sets it back to value2 again. At least in the version I'm using.
[Last edited Feb 04, 2013 22:17:59]
Login below to reply: