Members | Sign In
All Forums > Mission Scripting

*New Mission* Encounter at FarPoint

posted Jan 22, 2013 23:52:18 by TravisHead
The Enterprise has been sent to the outer rim on a diplomatic mission to deliver an envoy of Federation diplomats to the mysterious FarPoint Station on Deneb IV.
The diplomats are there to consider the local inhabitants petition to join the Federation in exchange for use of their strategically important new station.

A word of caution, however, as the Deneb sector is very near to the Ferengi borders. While not a serious threat the Ferengi have shown some interest in the sector.
*Any Ferengi vessels are to be assumed hostile*


Based on the classic first and second episodes of Star Trek TNG this mission will pit the crew against an unusual adversary and may require a captain to be quick on his feet.
Strong emphasis on helm and communications.

There are 4 possible Victory outcomes, 2 major, two minor.

Mission created for Artemis v1.66
Updated for v1.7

** **

Newly Updated for Mark's StarTrek TNG Mod!
** **

This is my first mission so any feedback is appreciated.
Thanks to Mike Substelny and bleep751 for their help in creating this mission!

Travis Head
[Last edited Jan 29, 2013 00:26:48]
page   first prev 1 2 3 4 5 next last
64 replies
TravisHead said Mar 31, 2013 12:46:33
Charlie said Mar 31, 2013 22:22:24
Just tried mission guys. Nice job!
mail.michael.roth said May 15, 2013 12:01:18
Hi Guys!
I'am fairly new to Artemis, starting with v1.7 (and an Upgrade to 1.72).
Unfortunately I always get an error when trying to play this mission.
I tried all combinations of 1.7, 1.72 with vanilla installation, Mark's TNG V1 and V2 Mod (using the appropriate mission files).

Everytime I get an assertion on the client saying:
Assertion failed!
Program: C:\Program Files\Artemis\Artemis.exe
File: .\OBJPlayer.cpp
Line: 162

Expression: pos.x > -SPACE_SIZE_W

This happens immediately after pressing "connect", before choosing stations.

Any Ideas on a fix?
MarkBell said May 15, 2013 12:06:29
First, how did the mod get installed? Was it through the Mod Loader or with the installer .bat from the mod files? Did the mission folders get dropped into the mission directory properly? Did you rename the mission folders? A little more background will be helpful :)

This assertion error keeps cropping up from time to time, I'm still not entirely sure what the problem is.
mail.michael.roth said May 15, 2013 16:12:13
Thanks for the quick reply!
Sorry I was not that verbose about how the mod was installed. I don't think that it's an error with your TNG Mod itself, because I get the same error wether or not it is installed.

But for the sake of completeness :)
I did not use any Mod Loader, but rather copied the mod folder into the artemis folder and used the installer .bat to copy the mission files.
Also I did a fresh installation of artemis (and the the upgrade 1.72) before installing any new Mod.

MarkBell said May 15, 2013 16:23:08
Try copying the Artemis program folder onto your base C drive and running it from there. (Not sure if it actually helps, but one of the debugging steps.) Did the installer .bat run with any errors?

Does the TNG mod run in invasion mode without errors? Try running on at least Diff 2 or 3 to make sure multiple types of enemies are spawned.
mail.michael.roth said May 15, 2013 16:30:24
My tests so far where with running Artemis from drive D.
I now tried the following:

-> Copy Artemis to C:\Artemis
-> Running Invasion mode in diff 4
-> Shot down one ship
-> (Got shot down by the other one... ;) )

No Problems so far, the installer .bat ran without errors

This was Version 1.7 with TNG Mod V1
[Last edited May 15, 2013 16:31:14]
mail.michael.roth said May 15, 2013 16:34:04
What I also failed to mention is that I run Server and Client on the same machine.
This does not give me any problems with other missions, but I will try running it across my network later on when I'm back from work.
MarkBell said May 15, 2013 16:35:45
I run server/client here all the time, so that shouldn't be a big problem. Ok, so invasion from c:\Artemis seems to work ok, does the mission?
mail.michael.roth said May 15, 2013 21:24:39
No, sadly it still gives the same result even across network :(

[EDIT] Installation on C:\ works with and without mod for invasion ONLY. Missions also work, but not the Farpoint mission. [/EDIT]

Are you running Artemis Version 1.7 as well ?

As of now, I tried all the version / mod combinations mentioned in the first post on my windows machine, and I tried vanilla installations (no mod) on two other machines, one using Linux and one using Windows.
I believe I am simply out of luck here.
My last shot would be trying the Mod Loader, but since it does not work without mod either, I don't believe the error is in the Mod :(
[Last edited May 15, 2013 21:26:31]
postbryan said Jul 11, 2013 03:42:50
So I've tried this mission several times, and didn't know what to do after I dock with Farpoint the first time. When I play I:

-Take the Diplomats to FarPoint Station, am told to leave orbit
-Get a message from Counselor Troi about the area
-Am told the Diplomants are prepared to come back aboard, and consider FarPoints offer (?)
-Dock and diplomats come aboard
-See Ferengi with shields of 5000 flying about, which I'm not inclined to engage
-Am told we're the last line of defense against the Ferengi, who don't engage us

Any ideas?
TravisHead said Jul 11, 2013 10:38:23
The Ferengi fleet is programmed to pursue you, the player, so they should make a b-line for you wherever you are on the map. Note that they move as a fleet so it may take them as long as the slowest ship.
The idea was that the player would engage the fleet as this makes the most tactical sense (harass and fall back to re-arm and repair if need be while they advance).

The story will not advance until that fleet has been destroyed.

Since you are the protector of DS9 and FarPoint (as they are petitioning to join the Federation) NOT engaging an enemy fleet would be tantamount to dereliction of duty and you would be removed from command.


Let me know if you have any issues with it from there. This mission was intended for a full crew so if you are playing solo you might find it difficult, but not impossible.
Note that FarPoint will regenerate your energy but will not re-arm you in your fight against the fleet. If you need missiles you will have to return to DS9.
I did, however include lots of anomalies and FarPoint so with unlimited energy you basically have unlimited homing missiles if you manage your energy.

TravisHead said Jul 11, 2013 10:52:36
Apologies PB, I just re-read your message and I missed the part about 5000 shields the first time.
Seems you are using the Star Trek Mod version in which case this is correct. The Ferengi ships in Mark's TNG mod do have 5000 shields.

The Federation ships have varying shield levels, you might want to try a different ship type if you find the Ferengi too strong. I am not sure how the Mod'd ships are balanced but I would assume a Ferengi ship is not superior to any Federation ship or that would be quite odd.
Mike_Substelny said Jul 11, 2013 12:47:40
I just read the script. Those Ferengi will only chase the player if within 20,000 and they will completely ignore a player in a nebula. I believe the Ferengi may go after stations, but until they threaten a station I don't see any motivation for the player to engage them.
"Damn the torpedoes! Four bells, Captain Drayton!"

(Likely actual words of Admiral David Farragut, USN, at the battle of Mobile Bay. Four bells was the signal for the engine room to make full steam ahead).
TravisHead said Jul 11, 2013 14:47:19
Not sure where you're getting 20K from, Mike. I just checked both the mod'd and unmod'd version and both XML's do not specify a range or Nebula limitation.
In the Mission Editor this translates to "anywhere on the map" which is what I was going for.

I also tested the non-mod'd version this morning and the fleet did come for me (granted I was AT FarPoint so they may have been going there but I doubt that).

Is there a default 20K limit? If so this fleet does not appear to be following it as they do chase the player.
Login below to reply: