Members | Sign In
All Forums > Mission Scripting

*New Mission* Encounter at FarPoint

posted Jan 22, 2013 23:52:18 by TravisHead
The Enterprise has been sent to the outer rim on a diplomatic mission to deliver an envoy of Federation diplomats to the mysterious FarPoint Station on Deneb IV.
The diplomats are there to consider the local inhabitants petition to join the Federation in exchange for use of their strategically important new station.

A word of caution, however, as the Deneb sector is very near to the Ferengi borders. While not a serious threat the Ferengi have shown some interest in the sector.
*Any Ferengi vessels are to be assumed hostile*


Based on the classic first and second episodes of Star Trek TNG this mission will pit the crew against an unusual adversary and may require a captain to be quick on his feet.
Strong emphasis on helm and communications.

There are 4 possible Victory outcomes, 2 major, two minor.

Mission created for Artemis v1.66
Updated for v1.7

** **

Newly Updated for Mark's StarTrek TNG Mod!
** **

This is my first mission so any feedback is appreciated.
Thanks to Mike Substelny and bleep751 for their help in creating this mission!

Travis Head
[Last edited Jan 29, 2013 00:26:48]
page   first prev 1 2 3 4 5 next last
64 replies
TravisHead said Feb 05, 2013 23:14:31
Alright. I have re-uploaded the MOD version with a few fixes, thanks Mark.
The file name is now the same as folder. The '<' is in place so the ship now spawns at DS9 as intended, no need to respawn. The enemies spawn as Ferengi. FarPoint looks the way I intended.
All is right with the Universe :)
Though for some reason the Mod does NOT like Miranda class. Warp is a snail's pace and it is basically unplayable, but I tested with all of the other classes and they work just fine (Intrepid is zippy!)

I think my next mission might be a bit less ... ambitious.
MarkBell said Feb 06, 2013 11:56:43
Excellent! Yeah no problems here, although I haven't tried it with the Miranda.
Charlie said Feb 06, 2013 15:15:38
Definitely looking forward to trying this!
EricMallory said Mar 13, 2013 19:34:58
Can I run this mission with stock Artemis or do I need to have Mark's StarTrek TNG Mod?
MarkBell said Mar 13, 2013 19:43:25
There are two mission files - the first is for the stock Artemis game and the second is for use with the TNG mod.
EricMallory said Mar 22, 2013 02:42:39
We played some missions this weekend, including this one. Last week, I was reading through this forum looking for missions to play and wishing there was more detail about the missions to help me decide. In an attempt to help the next crew decide if you want to play this mission, let me provide those details.

Latest version of Artemis verified it works on: 1.702
We played the non-mod version.
We were not familiar with the Encounter at FarPoint episode and were still able to be successful with the mission.
I'm not sure which Victory outcome we encountered.

I'd like to provide more feedback, but it's spoiler-like. Anyone know how I can post on the forum and hide it from those who don't want Spoilers?
Jonathan said Mar 25, 2013 02:15:32
I tried running this with my crew on Friday. We loved the setup, and the communications, etc. However, we got a bit stuck. After we dropped off the envoy, before we heard from Troi about the sadness we went Ferengi hunting, and killed them all (I think). After we returned to the station nothing seemed to happen (although we may have been too impatient). We looked around a bit more before giving up.

I think we'll try it again, but be a bit more patient and less trigger-happy next time. Some of our crew was new, so there was a real thirst for action ;)
TravisHead said Mar 28, 2013 11:58:12
Feel free to contact me directly with any feedback travis head AT g mail DOT com.
If you tell me how it ended I can elaborate on which ending that was.

Not sure what happened. Did the Ferengi fleet ever show up? Nothing you do after dropping off the envoy should stop that from happening. You shouldn't have been able to kill all of the scouts before the fleet arrives so if not then something went wrong apparently.

primetime34 said Mar 29, 2013 19:15:31
I am getting an error. It says:

"Failed to load mission file. Directory and filename mismatch?"

I am using the mission for Mark's TNG mod.

TravisHead said Mar 29, 2013 20:55:30
Usually when I see that it means the .xml file and folder names do not match. This should not be a problem as it would be a problem for everyone, but it's worth checking. The two have to be exact or Artemis doesn't know where to find the .xml file.

Probably also worth checking against other missions build for Mark's Mod in case there's a setup issue with the mod's install.
primetime34 said Mar 30, 2013 21:14:39
I tried running this mission with and without the mod. It didn't work. I am sure I am doing something wrong. So, here is what I have done:

Installed the mission through the Artemis Mod Loader. Tried running it, got the same error I mentioned above. So I uninstalled it from the Mod Loader and dropped it into the mission folder. Same error. Am I doing something wrong? How do you "install" or "apply" a mission? Thanks.
TravisHead said Mar 31, 2013 01:33:34
I've not used the mod loader but both the Mod version and non-mod version should work if you simply extract the folder from the zipped file and copy the folder into your Missions folder.
That should be all you need.

If you are not using Mark's mod then you will need to use the non-mod'd download link as there are differences between the two files.
In either case it should be as simple as downloading, unzipping and copying the Miss_FarPoint folder to your missions folder (probably C:\Program Files (x86)\Artemis\dat\Missions\MISS_FarPoint).
Make sure the XML is in that MISS_FarPoint folder and not C:\Program Files (x86)\Artemis\dat\Missions\MISS_FarPoint\MISS_FarPoint\.

If all else fails try the vanilla download in a fresh install of Artemis.

primetime34 said Mar 31, 2013 04:08:54
Okay, I finally got this to work. I had to reinstall Artemis to the root directory (C:\Artemis). Then, I had to copy the mission mod into the correct folder. Then it worked. Don't know why it wouldn't work through Program Files(x86), but this fixed it for me. Thanks! We played the mission for about 30 minutes before dinner tonight (myself and three of my children) and it was a blast!
TravisHead said Mar 31, 2013 10:29:57
Good to hear you got it working.
Thanks for the feedback :)
michaelhermanns said Mar 31, 2013 11:12:53
tested ist yesterday. really nice!
Login below to reply: