Members | Sign In
All Forums > Mission Scripting

*New Mission* Encounter at FarPoint

posted Jan 22, 2013 23:52:18 by TravisHead
The Enterprise has been sent to the outer rim on a diplomatic mission to deliver an envoy of Federation diplomats to the mysterious FarPoint Station on Deneb IV.
The diplomats are there to consider the local inhabitants petition to join the Federation in exchange for use of their strategically important new station.

A word of caution, however, as the Deneb sector is very near to the Ferengi borders. While not a serious threat the Ferengi have shown some interest in the sector.
*Any Ferengi vessels are to be assumed hostile*


Based on the classic first and second episodes of Star Trek TNG this mission will pit the crew against an unusual adversary and may require a captain to be quick on his feet.
Strong emphasis on helm and communications.

There are 4 possible Victory outcomes, 2 major, two minor.

Mission created for Artemis v1.66
Updated for v1.7

** **

Newly Updated for Mark's StarTrek TNG Mod!
** **

This is my first mission so any feedback is appreciated.
Thanks to Mike Substelny and bleep751 for their help in creating this mission!

Travis Head
[Last edited Jan 29, 2013 00:26:48]
page   first prev 1 2 3 4 5 next last
64 replies
TravisHead said Feb 02, 2013 19:45:08
The mission will set the diff to 3 but the difficulty is based around the story more so than the enemy strength.
Any ship would work but I assumed most would use the default Cruiser so that is what I tested with. If you chose a larger ship you should still be fine as there are plenty of anomalies to juice up with.

Let me know if you have any ship-specific issues. I would not recommend the scout for one of the possible methods of completing the mission (no spoilers) but with another method it should be just fine.
EricS.Macy said Feb 03, 2013 15:36:08
Thanks, we had a lot of fun, although we died when the space creature started attacking and then destroyed Farpoint station. We ran away towards DS9 and then crashed into a black hole. I loved that there were so many asteroids to dodge, it made it a lot more fun for the Helm station. Good mission, will do again sometime and try to finish it. I couldn't get the Star Trek mod to work with it but that's not a big deal, I think it was a problem with my installation of the mod, not your mission.
MarkBell said Feb 03, 2013 16:50:01
Can you explain the problem you were having with the mod? Either here or on the TNG mod page? I'm trying to figure out what bugs are plaguing the V2, because I'm only seeing some occasionally.
MarkBell said Feb 03, 2013 16:58:17
Now, what's really interesting is that the stock missions loads fine with the TNG mod loaded, although the TNG version of the mission hangs. Also, the mission in the MISS_FarPoint_Mark should be renamed to MISS_FarPoint_Mark to match the folder name.
MarkBell said Feb 03, 2013 17:24:39
Ok, so that was really fun! With the Stock Mission and the TNG mod, things worked really well. We succeeded with total victory! (victory a la the episode, that is) I will say there were some odd scaling things, but I'll see if I can't figure out why the TNG mission itself hangs. The FarPoint meatball will live in infamy amongst our crew now, btw :)
TravisHead said Feb 03, 2013 18:06:28
Eric & Mark, thanks for the feedback.
I'm having some trouble getting it to run from in the Mod now too. Not sure what's up.

Mark; where did the ship start? It's supposed to start right next to DS9 but when I use the mod it seems to be starting me up by FPS. And the station is NOT supposed to look like the screen shot :-Þ
In mine it looks right but you start in the wrong place. I have checked the code though and the start location IS correct. Not sure where that's coming from.

The station should have a massive "planet" beneath it in the MOD or a small asteroid that it surrounds in vanilla.

That meatball is anybody's guess.
EricS.Macy said Feb 03, 2013 18:29:37
Travis, when I used the TNG version of the mod at first the ship didn't spawn at all, when I clicked respawn player ship it spawned at farpoint station, however, in the vanilla mission it spawned correctly at DS9. BTW, farpoint station had a huge asteroid in the middle of it but my crew thought it was probably intentional since farpoint is on a planet.

Mark, I never saw any Star Trek ships although I only used the mod with the farpoint mission, I'll try again with a standard invasion mode. The error message I got said "d3d device has a non-zero reference count..." I installed the mod by copying the .rar into my artemis directory. Also I installed Artemis on my computers just by copy pasting the entire Artemis directory into each of them, not with the installer, in case that matters.
TravisHead said Feb 03, 2013 18:31:04
I am having the same issue with this mission and the mod (have to respawn).
It was not doing this at all during testing.
MarkBell said Feb 03, 2013 18:39:06
We spawned initially by DS9, that shot was when we made it over to FP. Again, this was the mission designed for the stock game, just running in the TNG Mod, so that would be the asteroid. ("Ferengi" ships were spawning cardassians and such since the race keys were off, but no big deal)

That's interesting. I'll try running the mod again to see what happened. Try running the Mod with the regular invasion mode and also with the regular FP mission, see if that helps.

EDIT - I also have to respawn in the TNG version of the mission, and it respawns by FP. How bizarre. Again, stock mission is ok.
[Last edited Feb 03, 2013 18:41:27]
MarkBell said Feb 03, 2013 18:43:07
Additionally, in the TNG Mission, FP station looks pretty much right.
[Last edited Feb 03, 2013 19:01:54]
TravisHead said Feb 03, 2013 18:54:24
Thanks for clarifying Mark.
I didn't test with the TNG mod and vanilla mission once I knew I had to modify the races and FPS. When I ran my first test I actually had a borg sphere spawn on me. Not fun. :)
MarkBell said Feb 03, 2013 19:06:26
hahaha whups :P Yeah, the spawned enemies ain't Ferengi, that's for sure.

So the TNG mission runs basically just fine on the TNG mod, asides from having to respawn the ship. Enemies came in at the appropriate times, all ferengi ships summoned, script played out appropriately, etc.

EDIT: maybe I was too close to FP when the monster came, but I didn't get the final message from the counselor as it was trying to kill me too :P
[Last edited Feb 03, 2013 19:15:30]
MarkBell said Feb 03, 2013 19:40:31
Ok, nope, I was more than 2000m from the station when it went, but the enemies are just sitting there and I'm not hearing anything from the counselor.

Ah ha! It's because when the player respawns, they respawn as "Artemis", thus the "Enterprise" can't be more than 2000 m from the entities. Hm. I'll see if I can figure out this respawn thing.
[Last edited Feb 03, 2013 19:40:48]
MarkBell said Feb 03, 2013 20:06:22
Success! If the ship is named Enterprise going into the mission, then when you respawn, the mission completes successfully since you're still named Enterprise. So, it'll work on 1.66, but we'll have to wait for 1.701 to be released for this to work properly (the 1.7 rename bug will crash the server if you delete the first letter of the ship name, and 1.701 should be fixing that). Kind of appropriate, I'd say :)

I still don't know why the respawn has to happen, but I'll see if I can figure it out.
[Last edited Feb 03, 2013 20:07:58]
MarkBell said Feb 03, 2013 20:15:27
Quadruple post! Yeah! :P

Found the bug:
<mission_data version="1.66" background_id_arme="">
<start name_arme="Start">
<!--Create the universe-->
create type="player" x="2001.0" y="0.0" z="95000.0" angle="270" name="Enterprise" />
^^ missing a < bracket. So, rename the file to MISS_FarPoint_Mark.xml and fix that, it should run no problems. It runs just fine with those fixes here, no ship naming required. Also, if you change DS9's hullkeys to "Orbital_Station" (take out "base") DS9 herself should appear.

Also also, all the friendly vessels have Starfleet as the raceID, not UFP. Doesn't really matter since there's only 1 friendly race, though.
[Last edited Feb 03, 2013 20:20:53]
Login below to reply: