Members | Sign In
All Forums > Hardware and LBE construction
avatar

Pixel Shaders

posted Nov 04, 2012 11:44:42 by MarkBell
My HP Pavillion ZV5000 has been sitting on a shelf for a few years, waiting for me to fix the power connector to the motherboard. Sez I, ooh, this might be a good Artemis box - it can run Mechwarrior 3, Mechwarrior 4, and FFXI, so it should handle Artemis just fine, right? Especially as a client.

Well, 162 Windows updates later (amazing how they pile up when it's been out of commission for 3 years), it turns out the graphics card doesn't support hardware shaders. It supports DX 9.0c, but the GeForce 440 Go has no hardware pixel shader support. Bugger. :P
page   1
3 replies
avatar
JSpaced said Nov 14, 2012 13:43:27
I think there's a software thing I came across for emulating that. I don't know how well it works, but "3danalyzer v236" (google to find the download) attempts to fool the application into thinking you've got missing elements like Hardware T&L and Pixel shading. I've never used it myself, but it's recommended for Neverwinter Nights 2, which makes similar demands.

I offer no guarantees of success here, but would be interesting to hear how you do with it.
"We should give him the send-off he deserves. He died saving us all. Prepare a Rocket-Shed for immediate launch."
avatar
MarkBell said Nov 16, 2012 13:12:28
bows deeply Well played, sir. That did the trick nicely. I enabled

emulate pixel shader caps
under Hardware Limits and

shaders
under Anti-Detect Mode. Then ran it!

"Features"
As a server, the 3D rendering is.... kinda trippy. Like very "altered state of mind" kinda trippy. I mean, it should be software emulating the shaders, but it isn't doing that properly. It's a neat effect, but not exactly standard. As a console, however, as long as you don't switch to the main view it renders just fine. Helm, Weapons, Comm, Science, Engineering - all showed up as expected, even rendered the 3d spinning translucent ship view. I didn't try the manual beam targeting window, but I suspect it would show up trippy.

For the game window select, it is a blank box. If you click in the right area, it pulls up the game, but it's click around until you find it :P It loads up just fine after that.

Thanks so much!!
avatar
MarkBell said Nov 16, 2012 13:20:40
Additional notes: I tried using emulate hardware T&L, but it crashed upon loading the game proper. So, yeah.
Login below to reply: