Members | Sign In
All Forums > Mission Scripting
avatar

Network sync problem - "topSpeed" property doesn't propogate

posted Jul 26, 2011 19:07:24 by Parias
Hitting a bit of a weird problem in setting up a little test mission. I'm creating a neutral ship, and the first thing I want it to do is stop roaming around on it's own (until I give it some scripted orders later on in the mission). Here's the applicable code from my start block (maybe there's a better way to do this):

<start>
<...>
<create type="neutral" x="15400" y="0" z="9000" angle="180" hulltype="0" name="Pegasus"/>
<set_object_property name="Pegasus" property="topSpeed" value="0" />
</start>

I'll then test the mission by running two Artemis instances - one as the server, one as a client. From the server I'll start the mission and everything works as expected.

Then, I'll join the session as a client - as soon as I do this, the other ship begins moving off on the client end, yet stays static on the server end. Something funky is going on =)

I'm fiddling about to find a workaround, but figured this might be worth reporting.
page   1
6 replies
avatar
Vorus said Jul 27, 2011 01:04:18
I once had a similar problem. It mysteriously went away, and I never figured out what was going on, nor what, if anything, I was doing wrong.
-----------
Khomerex nal Khesterex

The unofficial Artemis Wiki, your best source for Artemis Information
avatar
Parias said Jul 27, 2011 04:39:03
Heh. Found a workaround at least; when starting up, I just issue a "direct" command to tell Pegasus to move to the coordinates it's already at, at 0 throttle:

<direct name="Pegasus" pointX="15400" pointY="0" pointZ="9000" scriptThrottle="0"/>

Works a bit better than manually capping it's throttle. I actually tried this solution initially but gave up when it never worked for me; I later realized the "pointX", "pointY", etc declarations were case-sensitive. Woops.
avatar
Parias said Jul 27, 2011 07:50:52
To be honest though I'm still having a ton of trouble in general getting the AI to do what I want it to.. I'd like to set up a somewhat more scripted sort of mission involving tight control of 'friendly' AI-controlled vessels, but I'm getting nothing but grief in trying to get them to stop, go to specific locations, attack ships, and so on. If I use "direct" scripting to try and get a friendly ship to attack an enemy for example, it'll just remain in orbit around it's location, flying in circles only firing the occasional shot when it gets in range; it won't actually 'chase' the vessel or intercept / pursue it.

Are there any tips for wrestling the AI a little more under my control?
avatar
Mike_Substelny said Jul 27, 2011 13:33:44
The AI is opaque. I know of at least one bug in Neutral shipping AI that I recently pointed out to Thom which I believe will be fixed soon. In "Havoc in the Hamak Sector" a neutral destroyer will attack an enemy, but only if your Comms officer micromanages the steering. The AI will not change course on its own, even when the neutral destroyer has confirmed that it is ". . . turning to attack".

The behavior that you describe may or may not be the same bug. If it is the same, then this problem is not your fault and it should be fixed in a future release. Just in case, I suggest that you send your code to Thom.
"Damn the torpedoes! Four bells, Captain Drayton!"

(Likely actual words of Admiral David Farragut, USN, at the battle of Mobile Bay. Four bells was the signal for the engine room to make full steam ahead).
avatar
ThomRobertson said Jul 27, 2011 16:59:06
Yes, please email me any script you'd like me to look at, or show problems or weirdness. I'd really appreciate it.

In general, the game's ship AI needs a complete overhaul, and it's on the list.
Creator of Artemis
avatar
Parias said Jul 27, 2011 19:18:22
Awesome, thanks for offering to take a look at this - I've fired the script over to you with details on where the problem's occurring.

And yeah - we recently did a playthrough of Hamak and noticed the same thing; that destroyer just wouldn't do anything on it's own unless I micro-managed it. Gave me something more to do from Comms at least. =) It wouldn't surprise me if this is the same sort of problem.
[Last edited Jul 27, 2011 19:24:48]
Login below to reply: